DBA and SysAdmin World

May 23, 2009

SharePoint 2003 "Alert Me" does not work

Filed under: Problem, System Administrator — Tags: , , — solihinho @ 11:02 PM
SharePoint 2003 Issue
Our user suddenly raised an issue that she never got an alert anymore from her department portal if any changes happened on the document list. We’ve checked the SMTP etc and looks like it was working fine. Honestly we as SharePoint Administrator did not know how the way this alert works. So the last way we coulddo was asking for help from Microsoft support Big Grin.

Things need to be checked
Microsoft support asked us to do several things for investigating this issue. From this we also knew how SharePoint’s alert actually works.

1. Check whether we can get the first notification mail from SharePoint when we subscription “Alert me”.

2. Check whether we will get a new record in content database.
    · Actually, once we done some modification in library or list, the system will insert 
      a new record in database for "Mail Alert".
    · We can run the following command to check whether this record has be inserted to DB :
        SELECT * FROM dbo.EventCache ORDER BY eventtime DESC

3. Then, SharePoint timer job service will read the data from DB and send mail out.
    · NOTE : The timer job service will run every 5 minutes by default.
    · We also can run the following command to check it.
        Stsadm –o getproperty –propertyname job-immediate-alerts

4. After that, the record will be deleted from content database.

Problem Solve
From that guidance, we just realized that our SharePoint Timer service was off. After turned it on, the alert back to normal. If the guidance doesn’t help on your problem. It should be another component that you need to check such as the SMTP server etc.

Advertisements

Create a free website or blog at WordPress.com.